$re = '/^([^=\n\r]+?)\s*=\s*(\{([^}]*)\}|.*)/m';
$str = '[Group Variable]
name = Value
[Valid Extensions]
images = {
jpeg
png
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);