re = /^([^=\n\r]+?)\s*=\s*(\{([^}]*)\}|.*)/m
str = '[Group Variable]
name = Value
[Valid Extensions]
images = {
jpeg
png
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end