package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^=\n\r]+?)\s*=\s*(\{([^}]*)\}|.*)`)
var str = `[Group Variable]
name = Value
[Valid Extensions]
images = {
jpeg
png
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}