#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.js\b|.css\b)"
Local $sString = "/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/composer.json" & @CRLF & _
"/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/advanced-visitor-conditions/inc/conditions.js" & @CRLF & _
"/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/advanced-visitor-conditions/inc/conditions.min.js" & @CRLF & _
"/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/base.js" & @CRLF & _
"/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/base.min.js" & @CRLF & _
"/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/htmlParser.js" & @CRLF & _
"/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/postscribe.js" & @CRLF & _
"/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/flash/inc/flash.css" & @CRLF & _
"/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/flash/inc/flash.js" & @CRLF & _
"/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/vendor/composer/installed.json" & @CRLF & _
"/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/vendor/composer/installers/composer.json" & @CRLF & _
"/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/vendor/xrstf/composer-php52/composer.json"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")