$re = '/(.js\b|.css\b)/';
$str = '/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/composer.json
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/advanced-visitor-conditions/inc/conditions.js
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/advanced-visitor-conditions/inc/conditions.min.js
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/base.js
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/base.min.js
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/htmlParser.js
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/postscribe.js
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/flash/inc/flash.css
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/flash/inc/flash.js
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/vendor/composer/installed.json
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/vendor/composer/installers/composer.json
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/vendor/xrstf/composer-php52/composer.json';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);