use strict;
my $str = '/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/composer.json
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/advanced-visitor-conditions/inc/conditions.js
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/advanced-visitor-conditions/inc/conditions.min.js
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/base.js
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/base.min.js
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/htmlParser.js
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/postscribe.js
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/flash/inc/flash.css
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/flash/inc/flash.js
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/vendor/composer/installed.json
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/vendor/composer/installers/composer.json
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/vendor/xrstf/composer-php52/composer.json';
my $regex = qr/(.js\b|.css\b)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}