// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.js\b|.css\b)").unwrap();
let string = "/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/composer.json
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/advanced-visitor-conditions/inc/conditions.js
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/advanced-visitor-conditions/inc/conditions.min.js
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/base.js
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/base.min.js
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/htmlParser.js
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/postscribe.js
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/flash/inc/flash.css
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/modules/flash/inc/flash.js
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/vendor/composer/installed.json
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/vendor/composer/installers/composer.json
/srv/www/admanager/htdocs/wp-content/plugins/advanced-ads-pro/vendor/xrstf/composer-php52/composer.json";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}