using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*park(*SKIP)(*FAIL)|.*dog";
string input = @"That park has too many dogs";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}