const regex = /.*park(*SKIP)(*FAIL)|.*dog/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*park(*SKIP)(*FAIL)|.*dog', '')
const str = `That park has too many dogs`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}