package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*park(*SKIP)(*FAIL)|.*dog`)
var str = `That park has too many dogs`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}