using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([a-z\-]+)(?:\.com|\.fr|\.co.uk))";
string input = @"www.google.com
www.google.co.uk
www.foo-bar.com";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}