package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(([a-z\-]+)(?:\.com|\.fr|\.co.uk))`)
var str = `www.google.com
www.google.co.uk
www.foo-bar.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}