$re = '/(([a-z\-]+)(?:\.com|\.fr|\.co.uk))/';
$str = 'www.google.com
www.google.co.uk
www.foo-bar.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);