re = /(([a-z\-]+)(?:\.com|\.fr|\.co.uk))/
str = 'www.google.com
www.google.co.uk
www.foo-bar.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end