#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\"([^\"\n\\]|\\[abfnrtv?\"'\\0-7]|\\x[0-9a-fA-F])*\"|'([^'\n\\]|\\[abfnrtv?\"'\\0-7]|\\x[0-9a-fA-F])*'|\"\"\"((?!\"\"\")[^\\]|\\[abfnrtv?\"'\\0-7]|\\x[0-9a-fA-F])*\"\"\")$"
Local $sString = ""matches"" & @CRLF & _
""this also \" matches"" & @CRLF & _
"'matches'" & @CRLF & _
"'this also \' matches'" & @CRLF & _
""no" & @CRLF & _
"match"" & @CRLF & _
"'no" & @CRLF & _
"match'" & @CRLF & _
""""matches"""" & @CRLF & _
"" & @CRLF & _
"""" another" & @CRLF & _
"match """" & @CRLF & _
"" & @CRLF & _
"""" no """ match """" & @CRLF & _
"" & @CRLF & _
"""" this "\"" matches""""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")