const regex = new RegExp('^(\\"([^\\"\\n\\\\]|\\\\[abfnrtv?\\"\\'\\\\0-7]|\\\\x[0-9a-fA-F])*\\"|\\'([^\\'\\n\\\\]|\\\\[abfnrtv?\\"\\'\\\\0-7]|\\\\x[0-9a-fA-F])*\\'|\\"\\"\\"((?!\\"\\"\\")[^\\\\]|\\\\[abfnrtv?\\"\\'\\\\0-7]|\\\\x[0-9a-fA-F])*\\"\\"\\")$', 'gm')
const str = `"matches"
"this also \\" matches"
'matches'
'this also \\' matches'
"no
match"
'no
match'
"""matches"""
""" another
match """
""" no """ match """
""" this "\\"" matches"""`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}