using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\""([^\""\n\\]|\\[abfnrtv?\""'\\0-7]|\\x[0-9a-fA-F])*\""|'([^'\n\\]|\\[abfnrtv?\""'\\0-7]|\\x[0-9a-fA-F])*'|\""\""\""((?!\""\""\"")[^\\]|\\[abfnrtv?\""'\\0-7]|\\x[0-9a-fA-F])*\""\""\"")$";
string input = @"""matches""
""this also \"" matches""
'matches'
'this also \' matches'
""no
match""
'no
match'
""""matches""""
"""" another
match """"
"""" no """" match """"
"""" this ""\"" matches""""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}