re = /^(\"([^\"\n\\]|\\[abfnrtv?\"'\\0-7]|\\x[0-9a-fA-F])*\"|'([^'\n\\]|\\[abfnrtv?\"'\\0-7]|\\x[0-9a-fA-F])*'|\"\"\"((?!\"\"\")[^\\]|\\[abfnrtv?\"'\\0-7]|\\x[0-9a-fA-F])*\"\"\")$/m
str = '"matches"
"this also \\" matches"
\'matches\'
\'this also \\\' matches\'
"no
match"
\'no
match\'
"""matches"""
""" another
match """
""" no """ match """
""" this "\\"" matches"""'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end