using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\+\d{2}\s\d{2}\s\d{7}";
string input = @"+41 44 2429788
+1 212 9876543
001 212 9876543
+01 21 9876541
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}