$re = '/\+\d{2}\s\d{2}\s\d{7}/';
$str = '+41 44 2429788
+1 212 9876543
001 212 9876543
+01 21 9876541
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);