// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\+\d{2}\s\d{2}\s\d{7}").unwrap();
let string = "+41 44 2429788
+1 212 9876543
001 212 9876543
+01 21 9876541
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}