const regex = /\+\d{2}\s\d{2}\s\d{7}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\+\\d{2}\\s\\d{2}\\s\\d{7}', 'g')
const str = `+41 44 2429788
+1 212 9876543
001 212 9876543
+01 21 9876541
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}