#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ui)<(\w+)[^>]*>(?>[\p{Z}\p{C}]|<br\b[^>]*>)*</\1>"
Local $sString = "<strong class="a b"></strong>" & @CRLF & _
"<strong class="a b"><br class="a b" /></strong>" & @CRLF & _
"<strong class="a b"><br></strong>" & @CRLF & _
"<br class="a b" />" & @CRLF & _
"<strong class="a b"><br class="a b" /><br class="a b" /></strong>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")