using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(\w+)[^>]*>(?>[\p{Z}\p{C}]|<br\b[^>]*>)*</\1>";
string input = @"<strong class=""a b""></strong>
<strong class=""a b""><br class=""a b"" /></strong>
<strong class=""a b""><br></strong>
<br class=""a b"" />
<strong class=""a b""><br class=""a b"" /><br class=""a b"" /></strong>
";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}