import re
regex = re.compile(r"<(\w+)[^>]*>(?>[\p{Z}\p{C}]|<br\b[^>]*>)*</\1>", flags=re.UNICODE | re.IGNORECASE)
test_str = ("<strong class=\"a b\"></strong>\n"
"<strong class=\"a b\"><br class=\"a b\" /></strong>\n"
"<strong class=\"a b\"><br></strong>\n"
"<br class=\"a b\" />\n"
"<strong class=\"a b\"><br class=\"a b\" /><br class=\"a b\" /></strong>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")