re = /<(\w+)[^>]*>(?>[\p{Z}\p{C}]|<br\b[^>]*>)*<\/\1>/i
str = '<strong class="a b"></strong>
<strong class="a b"><br class="a b" /></strong>
<strong class="a b"><br></strong>
<br class="a b" />
<strong class="a b"><br class="a b" /><br class="a b" /></strong>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end