package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)hsoub_adplace = (\w*);`)
var str = `<script type="text/javascript"><!--
hsoub_adplace = XXXXXXXXXXXXXXX;
hsoub_adplace_size = 'XXXxXXX';
//--></script>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}