$re = '/hsoub_adplace = (\w*);/mi';
$str = '<script type="text/javascript"><!--
hsoub_adplace = XXXXXXXXXXXXXXX;
hsoub_adplace_size = \'XXXxXXX\';
//--></script>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);