re = /hsoub_adplace = (\w*);/mi
str = '<script type="text/javascript"><!--
hsoub_adplace = XXXXXXXXXXXXXXX;
hsoub_adplace_size = \'XXXxXXX\';
//--></script>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end