#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\+[^@]*"
Local $sString = "test.email+alex@gmail.com" & @CRLF & _
"test.email+@gmail.com" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)