import Foundation
let pattern = #"\+[^@]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
test.email+alex@gmail.com
test.email+@gmail.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)