package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\+[^@]*`)
var str = `test.email+alex@gmail.com
test.email+@gmail.com
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}