use strict;
my $str = 'test.email+alex@gmail.com
test.email+@gmail.com
';
my $regex = qr/\+[^@]*/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";