import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ # Start of the string (or line with m/multiline flag) \n"
+ "(?=.*\\d) # Lookahead that checks for at least one digit in the match\n"
+ "\\+? # An optional literal plus '+'\n"
+ "[#*\\d]{1,15} # one to fifteen of literal '#' or '*' or digit (\\d is [0-9])\n"
+ "$ # End of the string (line with m/multiline flag)";
final String string = "+1234\n"
+ "445678999\n"
+ "+#7897897\n"
+ "+345764756#775\n"
+ "+#\n"
+ "+*";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}