const regex = /^ # Start of the string (or line with m/multiline flag)
(?=.*\d) # Lookahead that checks for at least one digit in the match
\+? # An optional literal plus '+'
[#*\d]{1,15} # one to fifteen of literal '#' or '*' or digit (\d is [0-9])
$ # End of the string (line with m/multiline flag)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ # Start of the string (or line with m\/multiline flag)
(?=.*\\d) # Lookahead that checks for at least one digit in the match
\\+? # An optional literal plus \'+\'
[#*\\d]{1,15} # one to fifteen of literal \'#\' or \'*\' or digit (\\d is [0-9])
$ # End of the string (line with m\/multiline flag)', 'mg')
const str = `+1234
445678999
+#7897897
+345764756#775
+#
+*`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}