re = /^ # Start of the string (or line with m\/multiline flag)
(?=.*\d) # Lookahead that checks for at least one digit in the match
\+? # An optional literal plus '+'
[#*\d]{1,15} # one to fifteen of literal '#' or '*' or digit (\d is [0-9])
$ # End of the string (line with m\/multiline flag)/mx
str = '+1234
445678999
+#7897897
+345764756#775
+#
+*'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end