#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)playlist\.m3u8\?id=([^&=>]+).*?enableVideo\("([^"]*)"
Local $sString = "<script type="text/javascript">" & @CRLF & _
" var videoPlayer = document.createElement("video");" & @CRLF & _
" videoPlayer.setAttribute("id", "videoplayer");" & @CRLF & _
" videoPlayer.setAttribute("width", "580");" & @CRLF & _
" videoPlayer.setAttribute("height", "450");" & @CRLF & _
" videoPlayer.setAttribute("poster", "/static/images/logo.png");" & @CRLF & _
" videoPlayer.setAttribute("autoplay", true);" & @CRLF & _
" videoPlayer.setAttribute("controls", ""); " & @CRLF & _
"" & @CRLF & _
" var em = document.createElement("em");" & @CRLF & _
" em.innerHTML = "Sorry, your browser doesn't support HTML5 video.";" & @CRLF & _
" videoPlayer.appendChild(em);" & @CRLF & _
"" & @CRLF & _
" document.getElementById("player_div").appendChild(videoPlayer);" & @CRLF & _
"" & @CRLF & _
" function setupVideo() {" & @CRLF & _
" if (Hls.isSupported()) { " & @CRLF & _
" var video = document.getElementById('videoplayer');" & @CRLF & _
" var player = new Hls();" & @CRLF & _
" player.attachMedia(video);" & @CRLF & _
" player.on(Hls.Events.MEDIA_ATTACHED, function () {" & @CRLF & _
" var hlsUrl = "http://" + ea + ":8088/live/shid04/playlist.m3u8?id=95328&pk=";" & @CRLF & _
" hlsUrl = hlsUrl + enableVideo("5be02e45f5917b29199f8e5326499a6f8c6c7c9df86920b38c09bee46b050289");" & @CRLF & _
" player.loadSource(hlsUrl);" & @CRLF & _
" player.on(Hls.Events.MANIFEST_PARSED, function (event, data) { " & @CRLF & _
" video.play();" & @CRLF & _
" });" & @CRLF & _
" });" & @CRLF & _
" }else {" & @CRLF & _
" em.innerHTML = "Sorry, your browser doesn't support HTML5 video.";" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" </script>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")