using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"playlist\.m3u8\?id=([^&=>]+).*?enableVideo\(""([^""]*)";
string input = @"<script type=""text/javascript"">
var videoPlayer = document.createElement(""video"");
videoPlayer.setAttribute(""id"", ""videoplayer"");
videoPlayer.setAttribute(""width"", ""580"");
videoPlayer.setAttribute(""height"", ""450"");
videoPlayer.setAttribute(""poster"", ""/static/images/logo.png"");
videoPlayer.setAttribute(""autoplay"", true);
videoPlayer.setAttribute(""controls"", "");
var em = document.createElement(""em"");
em.innerHTML = ""Sorry, your browser doesn't support HTML5 video."";
videoPlayer.appendChild(em);
document.getElementById(""player_div"").appendChild(videoPlayer);
function setupVideo() {
if (Hls.isSupported()) {
var video = document.getElementById('videoplayer');
var player = new Hls();
player.attachMedia(video);
player.on(Hls.Events.MEDIA_ATTACHED, function () {
var hlsUrl = ""http://"" + ea + "":8088/live/shid04/playlist.m3u8?id=95328&pk="";
hlsUrl = hlsUrl + enableVideo(""5be02e45f5917b29199f8e5326499a6f8c6c7c9df86920b38c09bee46b050289"");
player.loadSource(hlsUrl);
player.on(Hls.Events.MANIFEST_PARSED, function (event, data) {
video.play();
});
});
}else {
em.innerHTML = ""Sorry, your browser doesn't support HTML5 video."";
}
}
</script>";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}