# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"playlist\.m3u8\?id=([^&=>]+).*?enableVideo\(\"([^\"]*)"
test_str = ("<script type=\"text/javascript\">\n"
" var videoPlayer = document.createElement(\"video\");\n"
" videoPlayer.setAttribute(\"id\", \"videoplayer\");\n"
" videoPlayer.setAttribute(\"width\", \"580\");\n"
" videoPlayer.setAttribute(\"height\", \"450\");\n"
" videoPlayer.setAttribute(\"poster\", \"/static/images/logo.png\");\n"
" videoPlayer.setAttribute(\"autoplay\", true);\n"
" videoPlayer.setAttribute(\"controls\", \"\"); \n\n"
" var em = document.createElement(\"em\");\n"
" em.innerHTML = \"Sorry, your browser doesn't support HTML5 video.\";\n"
" videoPlayer.appendChild(em);\n\n"
" document.getElementById(\"player_div\").appendChild(videoPlayer);\n\n"
" function setupVideo() {\n"
" if (Hls.isSupported()) { \n"
" var video = document.getElementById('videoplayer');\n"
" var player = new Hls();\n"
" player.attachMedia(video);\n"
" player.on(Hls.Events.MEDIA_ATTACHED, function () {\n"
" var hlsUrl = \"http://\" + ea + \":8088/live/shid04/playlist.m3u8?id=95328&pk=\";\n"
" hlsUrl = hlsUrl + enableVideo(\"5be02e45f5917b29199f8e5326499a6f8c6c7c9df86920b38c09bee46b050289\");\n"
" player.loadSource(hlsUrl);\n"
" player.on(Hls.Events.MANIFEST_PARSED, function (event, data) { \n"
" video.play();\n"
" });\n"
" });\n"
" }else {\n"
" em.innerHTML = \"Sorry, your browser doesn't support HTML5 video.\";\n"
" }\n"
" }\n\n"
" </script>")
matches = re.search(regex, test_str, re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.