import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "playlist\\.m3u8\\?id=([^&=>]+).*?enableVideo\\(\"([^\"]*)";
final String string = "<script type=\"text/javascript\">\n"
+ " var videoPlayer = document.createElement(\"video\");\n"
+ " videoPlayer.setAttribute(\"id\", \"videoplayer\");\n"
+ " videoPlayer.setAttribute(\"width\", \"580\");\n"
+ " videoPlayer.setAttribute(\"height\", \"450\");\n"
+ " videoPlayer.setAttribute(\"poster\", \"/static/images/logo.png\");\n"
+ " videoPlayer.setAttribute(\"autoplay\", true);\n"
+ " videoPlayer.setAttribute(\"controls\", \"\"); \n\n"
+ " var em = document.createElement(\"em\");\n"
+ " em.innerHTML = \"Sorry, your browser doesn't support HTML5 video.\";\n"
+ " videoPlayer.appendChild(em);\n\n"
+ " document.getElementById(\"player_div\").appendChild(videoPlayer);\n\n"
+ " function setupVideo() {\n"
+ " if (Hls.isSupported()) { \n"
+ " var video = document.getElementById('videoplayer');\n"
+ " var player = new Hls();\n"
+ " player.attachMedia(video);\n"
+ " player.on(Hls.Events.MEDIA_ATTACHED, function () {\n"
+ " var hlsUrl = \"http://\" + ea + \":8088/live/shid04/playlist.m3u8?id=95328&pk=\";\n"
+ " hlsUrl = hlsUrl + enableVideo(\"5be02e45f5917b29199f8e5326499a6f8c6c7c9df86920b38c09bee46b050289\");\n"
+ " player.loadSource(hlsUrl);\n"
+ " player.on(Hls.Events.MANIFEST_PARSED, function (event, data) { \n"
+ " video.play();\n"
+ " });\n"
+ " });\n"
+ " }else {\n"
+ " em.innerHTML = \"Sorry, your browser doesn't support HTML5 video.\";\n"
+ " }\n"
+ " }\n\n"
+ " </script>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}