import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{610}$)(?=.{71}(\\(\\.\\{8\\}\\)\\?\\\\.[^(]*){57}\\)\\{2\\}\\.\\{12\\}\\$\\/D$)((.{8})?\\/(.{8})?\\^(.{8})?\\((.{8})?\\?=(.{8})?\\.(.{8})?\\{610(.{8})?\\}(.{8})?\\$(.{8})?\\)(.{8})?\\((.{8})?\\?=(.{8})?\\.(.{8})?\\{71(.{8})?\\}(.{8})?\\((.{8})?\\\\(.{8})?\\((.{8})?\\\\(.{8})?\\.(.{8})?\\\\(.{8})?\\{8(.{8})?\\\\(.{8})?\\}(.{8})?\\\\(.{8})?\\)(.{8})?\\\\(.{8})?\\?(.{8})?\\\\(.{8})?\\\\(.{8})?\\.(.{8})?\\[(.{8})?\\^(.{8})?\\((.{8})?\\](.{8})?\\*(.{8})?\\)(.{8})?\\{57(.{8})?\\}(.{8})?\\\\(.{8})?\\)(.{8})?\\\\(.{8})?\\{2(.{8})?\\\\(.{8})?\\}(.{8})?\\\\(.{8})?\\.(.{8})?\\\\(.{8})?\\{12(.{8})?\\\\(.{8})?\\}(.{8})?\\\\(.{8})?\\$(.{8})?\\\\(.{8})?\\/D(.{8})?\\$(.{8})?\\)(.{8})?\\(){2}.{12}$";
final String string = "/^(?=.{610}$)(?=.{71}(\\(\\.\\{8\\}\\)\\?\\\\.[^(]*){57}\\)\\{2\\}\\.\\{12\\}\\$\\/D$)((.{8})?\\/(.{8})?\\^(.{8})?\\((.{8})?\\?=(.{8})?\\.(.{8})?\\{610(.{8})?\\}(.{8})?\\$(.{8})?\\)(.{8})?\\((.{8})?\\?=(.{8})?\\.(.{8})?\\{71(.{8})?\\}(.{8})?\\((.{8})?\\\\(.{8})?\\((.{8})?\\\\(.{8})?\\.(.{8})?\\\\(.{8})?\\{8(.{8})?\\\\(.{8})?\\}(.{8})?\\\\(.{8})?\\)(.{8})?\\\\(.{8})?\\?(.{8})?\\\\(.{8})?\\\\(.{8})?\\.(.{8})?\\[(.{8})?\\^(.{8})?\\((.{8})?\\](.{8})?\\*(.{8})?\\)(.{8})?\\{57(.{8})?\\}(.{8})?\\\\(.{8})?\\)(.{8})?\\\\(.{8})?\\{2(.{8})?\\\\(.{8})?\\}(.{8})?\\\\(.{8})?\\.(.{8})?\\\\(.{8})?\\{12(.{8})?\\\\(.{8})?\\}(.{8})?\\\\(.{8})?\\$(.{8})?\\\\(.{8})?\\/D(.{8})?\\$(.{8})?\\)(.{8})?\\(){2}.{12}$/D";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}