re = /^(?=.{610}$)(?=.{71}(\(\.\{8\}\)\?\\.[^(]*){57}\)\{2\}\.\{12\}\$\/D$)((.{8})?\/(.{8})?\^(.{8})?\((.{8})?\?=(.{8})?\.(.{8})?\{610(.{8})?\}(.{8})?\$(.{8})?\)(.{8})?\((.{8})?\?=(.{8})?\.(.{8})?\{71(.{8})?\}(.{8})?\((.{8})?\\(.{8})?\((.{8})?\\(.{8})?\.(.{8})?\\(.{8})?\{8(.{8})?\\(.{8})?\}(.{8})?\\(.{8})?\)(.{8})?\\(.{8})?\?(.{8})?\\(.{8})?\\(.{8})?\.(.{8})?\[(.{8})?\^(.{8})?\((.{8})?\](.{8})?\*(.{8})?\)(.{8})?\{57(.{8})?\}(.{8})?\\(.{8})?\)(.{8})?\\(.{8})?\{2(.{8})?\\(.{8})?\}(.{8})?\\(.{8})?\.(.{8})?\\(.{8})?\{12(.{8})?\\(.{8})?\}(.{8})?\\(.{8})?\$(.{8})?\\(.{8})?\/D(.{8})?\$(.{8})?\)(.{8})?\(){2}.{12}$/
str = '/^(?=.{610}$)(?=.{71}(\\(\\.\\{8\\}\\)\\?\\\\.[^(]*){57}\\)\\{2\\}\\.\\{12\\}\\$\\/D$)((.{8})?\\/(.{8})?\\^(.{8})?\\((.{8})?\\?=(.{8})?\\.(.{8})?\\{610(.{8})?\\}(.{8})?\\$(.{8})?\\)(.{8})?\\((.{8})?\\?=(.{8})?\\.(.{8})?\\{71(.{8})?\\}(.{8})?\\((.{8})?\\\\(.{8})?\\((.{8})?\\\\(.{8})?\\.(.{8})?\\\\(.{8})?\\{8(.{8})?\\\\(.{8})?\\}(.{8})?\\\\(.{8})?\\)(.{8})?\\\\(.{8})?\\?(.{8})?\\\\(.{8})?\\\\(.{8})?\\.(.{8})?\\[(.{8})?\\^(.{8})?\\((.{8})?\\](.{8})?\\*(.{8})?\\)(.{8})?\\{57(.{8})?\\}(.{8})?\\\\(.{8})?\\)(.{8})?\\\\(.{8})?\\{2(.{8})?\\\\(.{8})?\\}(.{8})?\\\\(.{8})?\\.(.{8})?\\\\(.{8})?\\{12(.{8})?\\\\(.{8})?\\}(.{8})?\\\\(.{8})?\\$(.{8})?\\\\(.{8})?\\/D(.{8})?\\$(.{8})?\\)(.{8})?\\(){2}.{12}$/D'
# Print the match result
str.match(re) do |match|
puts match.to_s
end