const regex = /^(?=.{610}$)(?=.{71}(\(\.\{8\}\)\?\\.[^(]*){57}\)\{2\}\.\{12\}\$\/D$)((.{8})?\/(.{8})?\^(.{8})?\((.{8})?\?=(.{8})?\.(.{8})?\{610(.{8})?\}(.{8})?\$(.{8})?\)(.{8})?\((.{8})?\?=(.{8})?\.(.{8})?\{71(.{8})?\}(.{8})?\((.{8})?\\(.{8})?\((.{8})?\\(.{8})?\.(.{8})?\\(.{8})?\{8(.{8})?\\(.{8})?\}(.{8})?\\(.{8})?\)(.{8})?\\(.{8})?\?(.{8})?\\(.{8})?\\(.{8})?\.(.{8})?\[(.{8})?\^(.{8})?\((.{8})?\](.{8})?\*(.{8})?\)(.{8})?\{57(.{8})?\}(.{8})?\\(.{8})?\)(.{8})?\\(.{8})?\{2(.{8})?\\(.{8})?\}(.{8})?\\(.{8})?\.(.{8})?\\(.{8})?\{12(.{8})?\\(.{8})?\}(.{8})?\\(.{8})?\$(.{8})?\\(.{8})?\/D(.{8})?\$(.{8})?\)(.{8})?\(){2}.{12}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{610}$)(?=.{71}(\\(\\.\\{8\\}\\)\\?\\\\.[^(]*){57}\\)\\{2\\}\\.\\{12\\}\\$\\\/D$)((.{8})?\\\/(.{8})?\\^(.{8})?\\((.{8})?\\?=(.{8})?\\.(.{8})?\\{610(.{8})?\\}(.{8})?\\$(.{8})?\\)(.{8})?\\((.{8})?\\?=(.{8})?\\.(.{8})?\\{71(.{8})?\\}(.{8})?\\((.{8})?\\\\(.{8})?\\((.{8})?\\\\(.{8})?\\.(.{8})?\\\\(.{8})?\\{8(.{8})?\\\\(.{8})?\\}(.{8})?\\\\(.{8})?\\)(.{8})?\\\\(.{8})?\\?(.{8})?\\\\(.{8})?\\\\(.{8})?\\.(.{8})?\\[(.{8})?\\^(.{8})?\\((.{8})?\\](.{8})?\\*(.{8})?\\)(.{8})?\\{57(.{8})?\\}(.{8})?\\\\(.{8})?\\)(.{8})?\\\\(.{8})?\\{2(.{8})?\\\\(.{8})?\\}(.{8})?\\\\(.{8})?\\.(.{8})?\\\\(.{8})?\\{12(.{8})?\\\\(.{8})?\\}(.{8})?\\\\(.{8})?\\$(.{8})?\\\\(.{8})?\\\/D(.{8})?\\$(.{8})?\\)(.{8})?\\(){2}.{12}$', '')
const str = `/^(?=.{610}\$)(?=.{71}(\\(\\.\\{8\\}\\)\\?\\\\.[^(]*){57}\\)\\{2\\}\\.\\{12\\}\\\$\\/D\$)((.{8})?\\/(.{8})?\\^(.{8})?\\((.{8})?\\?=(.{8})?\\.(.{8})?\\{610(.{8})?\\}(.{8})?\\\$(.{8})?\\)(.{8})?\\((.{8})?\\?=(.{8})?\\.(.{8})?\\{71(.{8})?\\}(.{8})?\\((.{8})?\\\\(.{8})?\\((.{8})?\\\\(.{8})?\\.(.{8})?\\\\(.{8})?\\{8(.{8})?\\\\(.{8})?\\}(.{8})?\\\\(.{8})?\\)(.{8})?\\\\(.{8})?\\?(.{8})?\\\\(.{8})?\\\\(.{8})?\\.(.{8})?\\[(.{8})?\\^(.{8})?\\((.{8})?\\](.{8})?\\*(.{8})?\\)(.{8})?\\{57(.{8})?\\}(.{8})?\\\\(.{8})?\\)(.{8})?\\\\(.{8})?\\{2(.{8})?\\\\(.{8})?\\}(.{8})?\\\\(.{8})?\\.(.{8})?\\\\(.{8})?\\{12(.{8})?\\\\(.{8})?\\}(.{8})?\\\\(.{8})?\\\$(.{8})?\\\\(.{8})?\\/D(.{8})?\\\$(.{8})?\\)(.{8})?\\(){2}.{12}\$/D`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}