use strict;
my $str = '/^(?=.{610}$)(?=.{71}(\\(\\.\\{8\\}\\)\\?\\\\.[^(]*){57}\\)\\{2\\}\\.\\{12\\}\\$\\/D$)((.{8})?\\/(.{8})?\\^(.{8})?\\((.{8})?\\?=(.{8})?\\.(.{8})?\\{610(.{8})?\\}(.{8})?\\$(.{8})?\\)(.{8})?\\((.{8})?\\?=(.{8})?\\.(.{8})?\\{71(.{8})?\\}(.{8})?\\((.{8})?\\\\(.{8})?\\((.{8})?\\\\(.{8})?\\.(.{8})?\\\\(.{8})?\\{8(.{8})?\\\\(.{8})?\\}(.{8})?\\\\(.{8})?\\)(.{8})?\\\\(.{8})?\\?(.{8})?\\\\(.{8})?\\\\(.{8})?\\.(.{8})?\\[(.{8})?\\^(.{8})?\\((.{8})?\\](.{8})?\\*(.{8})?\\)(.{8})?\\{57(.{8})?\\}(.{8})?\\\\(.{8})?\\)(.{8})?\\\\(.{8})?\\{2(.{8})?\\\\(.{8})?\\}(.{8})?\\\\(.{8})?\\.(.{8})?\\\\(.{8})?\\{12(.{8})?\\\\(.{8})?\\}(.{8})?\\\\(.{8})?\\$(.{8})?\\\\(.{8})?\\/D(.{8})?\\$(.{8})?\\)(.{8})?\\(){2}.{12}$/D';
my $regex = qr/^(?=.{610}$)(?=.{71}(\(\.\{8\}\)\?\\.[^(]*){57}\)\{2\}\.\{12\}\$\/D$)((.{8})?\/(.{8})?\^(.{8})?\((.{8})?\?=(.{8})?\.(.{8})?\{610(.{8})?\}(.{8})?\$(.{8})?\)(.{8})?\((.{8})?\?=(.{8})?\.(.{8})?\{71(.{8})?\}(.{8})?\((.{8})?\\(.{8})?\((.{8})?\\(.{8})?\.(.{8})?\\(.{8})?\{8(.{8})?\\(.{8})?\}(.{8})?\\(.{8})?\)(.{8})?\\(.{8})?\?(.{8})?\\(.{8})?\\(.{8})?\.(.{8})?\[(.{8})?\^(.{8})?\((.{8})?\](.{8})?\*(.{8})?\)(.{8})?\{57(.{8})?\}(.{8})?\\(.{8})?\)(.{8})?\\(.{8})?\{2(.{8})?\\(.{8})?\}(.{8})?\\(.{8})?\.(.{8})?\\(.{8})?\{12(.{8})?\\(.{8})?\}(.{8})?\\(.{8})?\$(.{8})?\\(.{8})?\/D(.{8})?\$(.{8})?\)(.{8})?\(){2}.{12}$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}