$re = '/^([0-9]+(\.[0-9]+)?)/m';
$str = '123.345
123.345.654
123.42353453
1243453
346546.645654654654';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);