re = /^([0-9]+(\.[0-9]+)?)/m
str = '123.345
123.345.654
123.42353453
1243453
346546.645654654654'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end