import re
regex = re.compile(r"^([0-9]+(\.[0-9]+)?)", flags=re.MULTILINE)
test_str = ("123.345\n"
"123.345.654\n"
"123.42353453\n"
"1243453\n"
"346546.645654654654")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")