using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Country:[\s]+(\S{2})";
string input = @"City: Redmond
StateProv: WA
PostalCode: 98052
Country: US";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}