package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)Country:[\s]+(\S{2})`)
var str = `City: Redmond
StateProv: WA
PostalCode: 98052
Country: US`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}