const regex = /Country:[\s]+(\S{2})/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Country:[\\s]+(\\S{2})', 'i')
const str = `City: Redmond
StateProv: WA
PostalCode: 98052
Country: US`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}